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ments of the rights of third parties, which may result from its use.
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Product Warranty (5 years)
Advantech warrants to you, the original purchaser, that each of its products will be
free from defects in materials and workmanship for five years from the date of pur-
chase. 

This warranty does not apply to any products which have been repaired or altered by
persons other than repair personnel authorized by Advantech, or which have been
subject to misuse, abuse, accident or improper installation. Advantech assumes no
liability under the terms of this warranty as a consequence of such events.

Because of Advantech’s high quality-control standards and rigorous testing, most of
our customers never need to use our repair service. If an Advantech product is defec-
tive, it will be repaired or replaced at no charge during the warranty period. For out of-
warranty repairs, you will be billed according to the cost of replacement materials,
service time and freight. Please consult your dealer for more details.

If you think you have a defective product, follow these steps:

1. Collect all the information about the problem encountered. (For example, CPU 
speed, Advantech products used, other hardware and software used, etc.) Note 
anything abnormal and list any on screen messages you get when the problem 
occurs.

2. Call your dealer and describe the problem. Please have your manual, product, 
and any helpful information readily available.

3. If your product is diagnosed as defective, obtain an RMA (return merchandize 
authorization) number from your dealer. This allows us to process your return 
more quickly.

4. Carefully pack the defective product, a fully-completed Repair and Replacement 
Order Card and a photocopy proof of purchase date (such as your sales receipt) 
in a shippable container. A product returned without proof of the purchase date 
is not eligible for warranty service.

5. Write the RMA number visibly on the outside of the package and ship it prepaid 
to your dealer.
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Declaration of Conformity

CE

This product has passed the CE test for environmental specifications when shielded
cables are used for external wiring. We recommend the use of shielded cables. This
kind of cable is available from Advantech. Please contact your local supplier for
ordering information.

This product has passed the CE test for environmental specifications. Test conditions
for passing included the equipment being operated within an industrial enclosure. In
order to protect the product from being damaged by ESD (Electrostatic Discharge)
and EMI leakage, we strongly recommend the use of CE-compliant industrial enclo-
sure products.

FCC Class A

Note: This equipment has been tested and found to comply with the limits for a Class
A digital device, pursuant to part 15 of the FCC Rules. These limits are designed to
provide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications. Opera-
tion of this equipment in a residential area is likely to cause harmful interference in
which case the user will be required to correct the interference at his own expense.

Technical Support and Assistance
1. Visit the Advantech web site at www.advantech.com/support where you can find 

the latest information about the product.
2. Contact your distributor, sales representative, or Advantech's customer service 

center for technical support if you need additional assistance. Please have the 
following information ready before you call:
– Product name and serial number
– Description of your peripheral attachments
– Description of your software (operating system, version, application software, 

etc.)
– A complete description of the problem
– The exact wording of any error messages
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Warnings, Cautions and Notes

Document Feedback
To assist us in making improvements to this manual, we would welcome comments
and constructive criticism. Please send all such - in writing to: support@advan-
tech.com

Packing List
Before setting up the system, check that the items listed below are included and in
good condition. If any item does not accord with the table, please contact your dealer
immediately.

 1 x Serial Device Server
 1 x Wall-mounting Brackets
 1 x DIN-Rail Mounting Bracket and Screws
 1 x CD-ROM

Warning! Warnings indicate conditions, which if not observed, can cause personal 
injury!

Caution! Cautions are included to help you avoid damaging hardware or losing 
data. e.g.

There is a danger of a new battery exploding if it is incorrectly installed. 
Do not attempt to recharge, force open, or heat the battery. Replace the 
battery only with the same or equivalent type recommended by the man-
ufacturer. Discard used batteries according to the manufacturer's 
instructions.

Note! Notes provide optional additional information.
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Safety Instructions
1. Read these safety instructions carefully.
2. Keep this User Manual for later reference.
3. Disconnect this equipment from any AC outlet before cleaning. Use a damp 

cloth. Do not use liquid or spray detergents for cleaning.
4. For plug-in equipment, the power outlet socket must be located near the equip-

ment and must be easily accessible.
5. Keep this equipment away from humidity.
6. Put this equipment on a reliable surface during installation. Dropping it or letting 

it fall may cause damage.
7. The openings on the enclosure are for air convection. Protect the equipment 

from overheating. DO NOT COVER THE OPENINGS.
8. Make sure the voltage of the power source is correct before connecting the 

equipment to the power outlet.
9. Position the power cord so that people cannot step on it. Do not place anything 

over the power cord.
10. All cautions and warnings on the equipment should be noted.
11. If the equipment is not used for a long time, disconnect it from the power source 

to avoid damage by transient overvoltage.
12. Never pour any liquid into an opening. This may cause fire or electrical shock.
13. Never open the equipment. For safety reasons, the equipment should be 

opened only by qualified service personnel.
14. If one of the following situations arises, get the equipment checked by service 

personnel:
15. The power cord or plug is damaged.
16. Liquid has penetrated into the equipment.
17. The equipment has been exposed to moisture.
18. The equipment does not work well, or you cannot get it to work according to the 

user's manual.
19. The equipment has been dropped and damaged.
20. The equipment has obvious signs of breakage.
21. CAUTION: DANGER OF EXPLOSION IF BATTERY IS INCORRECTLY 

REPLACED. REPLACE ONLY WITH THE SAME OR EQUIVALENT TYPE 
RECOMMENDED BY THE MANUFACTURER, DISCARD USED BATTERIES 
ACCORDING TO THE MANUFACTURER'S INSTRUCTIONS.

22. DO NOT LEAVE THIS EQUIPMENT IN AN ENVIRONMENT WHERE THE 
STORAGE TEMPERATURE MAY GO BELOW -40°C (-40°F) OR ABOVE 75°C 
(167°F). THIS COULD DAMAGE THE EQUIPMENT. THE EQUIPMENT 
SHOULD BE IN A CONTROLLED ENVIRONMENT.

23. This is building-in equipment and shall be installed in a suitable enclosure.

Warning! Hot surface. Do not touch.
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Safety Precaution - Static Electricity
Follow these simple precautions to protect yourself from harm and the products from
damage.

 To avoid electrical shock, always disconnect the power from your PC chassis 
before you work on it. Don't touch any components on the CPU card or other 
cards while the PC is on.

 Disconnect power before making any configuration changes. The sudden rush 
of power as you connect a jumper or install a card may damage sensitive elec-
tronic components.
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Chapter 1

1Overview



1.1 Introduction
The EKI-1528I and EKI-1528CI are network-based serial device servers that connect
RS-232/422/485 serial devices, such as PLC, meters, sensors, and barcode readers,
directly to a TCP/IP network.

Once connected through a EKI-1528 series serial server, devices are able to send
and receive data through a network. This extends the traditional COM ports of a PC,
with access over a TCP/IP network. Through networking, you can control and moni-
tor remote serial devices over either a LAN or WAN. Since the EKI-1528 is connected
through a TCP/IP network, you may need to know some basic facts about networking
in order to connect the server correctly.

The EKI-1528I and EKI-1528CI feature two independent Ethernet ports and MAC
addresses to provide a redundant network mechanism to avoid data loss. The EKI-
1528I and EKI-1528CI provide various operations: COM port redirection mode (Vir-
tual COM Port mode), TCP Server/ Client mode, UDP mode, Control mode and
RFC2217 mode. Detailed descriptions of each operation are provided in a later chap-
ter.

1.2 Device Features
 Provides 2 x 10/100 Mbps Ethernet ports for LAN redundancy
 Provides COM port redirection (Virtual COM), TCP and UDP operation modes
 Supports up to 921.6 kbps, and any baud rate setting
 Allows a max. of 5 hosts to access one serial port
 Allows a max. of 16 hosts to be accessed as TCP client mode
 Built-in 15 KV ESD protection for all serial signals
 Provides rich configuration access, including: Windows utility, Telnet console, 

and Web Browser
 Supports 32-bit/64-bit Windows 2000/XP/Vista/7/8/8.1, Windows Server 2003/

2008/2012, Windows CE 5.0, and Linux
 Automatic RS-485 data flow control
 Supports line to line 4 KV, line to ground 8 KV surge protection
 Supports a wide operating temperature (I models only)
 Supports isolation and wide operating temperature (CI models only)

1.3 Device Specifications

Specifications Description

Interface I/O Port  EKI-1528I: 2 x RJ45 + 8 x RS-232/422/485
 EKI-1528CI: 2 x RJ45 + 8 x RS-422/485

Power Connector 6-pin removable screw terminal (power & relay)

Physical Enclosure Metal with solid mounting hardware

Installation DIN-Rail and Wall mount

Dimensions 
(W x H x D)

86 x 140 x 95mm (3.38" x 5.51" x 3.74")

LED Display System LED Power 1, Power 2, Status

Port LED  AN: Speed, Link/Active
 Serial: Tx, Rx
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Environment Operating 
Temperature

-40°C ~ 70°C (-40°F ~ 158°F)

Storage 
Temperature

-40°C ~ 85°C (-40°F ~ 185°F)

Ambient Relative 
Humidity

10 ~ 95% (non-condensing)

Ethernet 
Communications

Compatibility IEEE 802.3, IEEE 802.3u

Speed 10/100 Mbps

Port Connector 8-pin RJ45

Protection Built-in 1.5 KV magnetic isolation

Serial 
Communications

Port Type RS-232/422/485, software selectable

Port Connector DB9 male

Data Bits 5, 6, 7, 8

Stop Bits 1, 1.5, 2

Parity None, Odd, Even, Space, Mark

Flow Control XON/XOFF, RTS/CTS, DTR/DSR

Baud Rate 50 bps ~ 921.6 kbps, any baud rate setting

Protection Built-in 15 KV ESD for all signals

Power Power 
Consumption

 EKI-1528I: 5W
 EKI-1528CI: 6W

Power Input 12 ~ 48VDC, redundant dual inputs

Software Driver Support 32-bit/64-bit Windows 2000/XP/Vista/7/8/8.1, Win-
dows Server 2003/2008/2012, Windows CE 5.0, and 
Linux

Operation Modes  COM port redirection mode (Virtual COM)
 TCP/UDP server (polling) mode
 TCP/UDP client (event handling) mode
 Pair connection (peer to peer) mode

Configuration Windows utility, Telnet console, Web Browser

Management SNMP MIB-II

Regulatory 
Approvals

EMC CE, FCC Part 15 Subpart B (Class A)

Specifications Description
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2.1 Hardware Overview

2.1.1 Front View
The following view applies to EKI-1528I and EKI-1528CI.

Figure 2.1 Front View

No. Item Description

1 System LED panel See “LED Indicators” on page 7 for further details.

2 Default button Press at least 10secs to reset device to default settings.

3 ETH port RJ45 ports x 2. See “LED Indicators” on page 7 for further details.

4 Serial port DB9 pinout, supports RS-232/422/485. See “LED Indicators” on 
page 7 for further details.

1

2

1 3 5 7

2 4 6 8

LAN

Default

TxRx TxRx TxRx TxRx

TxRx TxRx TxRx TxRx

P1 P2 Status

Serial Ports

EKI-1528I

1

2

3

4
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2.1.2 Rear View

Figure 2.2 Rear View

2.1.3 Top View

Figure 2.3 Top View

No. Item Description

1 Wall mounting holes Screw holes (x6) used in the installation of a wall mounting plate

2 DIN-Rail mounting 
plate

Mounting plate used for the installation to a standard DIN rail

1

1

2

No. Item Description

1 Terminal block Connect cabling for power and alarm wiring

2 Ground terminal Screw terminal used to ground chassis

PWR2

P-Fail

DC12-48VPWR1

V2-   V2+V1-   V1+

1A@24V

1 2
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2.1.4 LED Indicators

Figure 2.4 System LED Panel

No. LED Name LED Color Description

1 P1 Green Power 1 is on

Off Power 1 is off, or power error condition exists

2 P2 Green Power 2 is on

Off Power 2 is off, or power error condition exists

3 Status Amber Blinking: System is ready (1cycle/sec.)
Steady on: The device server has been located 
by utility’s location function

Off System is not working

4 Ethernet Amber Blinking: Ethernet port is transmitting or receiv-
ing data
Steady on: Ethernet has a good link for 10Mbps 
or 100Mbps operations

Green On: 100Mbps Ethernet connection
Off: 10Mbps Ethernet connection

5 Serial Amber Serial port is transmitting data

Green Serial port is receiving data

Off No data is being transmitted or received through 
the serial port

1

2

LAN

Default

TxRx TxRx TxRx TxRx

P1 P2 Status

EKI-1528I

1 2 3

4

5
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2.1.5 Dimensions

Figure 2.5 Dimensions

2.2 Connecting Hardware

2.2.1 Choosing a Location

2.2.1.1 DIN Rail Mounting
The DIN rail mount option is the quickest installation option. Additionally, it optimizes
the use of rail space.

The metal DIN rail kit is secured to the rear of the serial device server. The device
can be mounted onto a standard 48.5mm (1.91”) x 66mm (2.6”) height DIN rail. The

86.00

83.50
50.67

86.60 95

15
0

9
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devices can be mounted vertically or horizontally. Refer to the following guidelines for
further information.

Installing the DIN-Rail Mounting Kit

1. Insert the top back of the mounting bracket over the DIN rail.
2. Push the bottom of the server towards the DIN rail until it snaps into place.
\

Figure 2.6 Installing the DIN-Rail Mounting Kit

Removing the DIN-Rail Mounting Kit

1. Push the server down to free the bottom of the plate from the DIN rail.
2. Rotate the bottom of the device towards you and away from the DIN rail.

Note! A corrosion-free mounting rail is advisable.

When installing, make sure to allow for enough space to properly install 
the cabling.

1

2

DIN Rail
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3. Once the bottom is clear of the DIN rail, lift the device straight up to unhook it 
from the DIN rail.

\

Figure 2.7 Removing the DIN-Rail

2.2.1.2 Wall-Mounting
The wall mounting option provides better shock and vibration resistance than the DIN
rail vertical mount.

Before the device can be mounted on a wall, you will need to remove the DIN rail
plate.

1. Rotate the device to the rear side and locate the DIN mounting plate.
2. Remove the screws securing the DIN mounting plate to the rear panel of the 

server.
3. Remove the DIN mounting plate. Store the DIN mounting plate and provided 

screws for later use.
4. Align the wall mounting plates on the rear side. The screw holes on the device 

and the mounting plates must be aligned, see the following illustration.

1

2

DIN Rail

Note! When installing, make sure to allow for enough space to properly install 
the cabling.
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5. Secure the wall mount plates with M3 screws, see the following figure.

Figure 2.8 Installing Wall Mount Plates

Once the wall mounting plates are secure on the device, you will need to
attach the wall screws (x6).

6. Locate the installation site and place the server against the wall, making sure it 
is the final installation location.

7. Use the wall mount plates as a guide to mark the locations of the screw holes.
8. Drill four holes over the four marked locations on the wall, keeping in mind that 

the holes must accommodate wall sinks in addition to the screws.
9. Insert the wall sinks into the walls.
10. Insert the screws into the wall sinks.

Figure 2.9 Securing Wall Mounting Screws

Note!  Make sure the screws dimensions are suitable for use with the wall 
mounting plate.

 Do not completely tighten the screws into the wall. A final adjustment may 
be needed before fully securing the wall mounting plates on the wall.

> 6 mm

3.0 mm
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11. Align the wall mount plate over the screws on the wall.
12. Install the wall mount plate on the screws and slide it forward to lock in place, 

see the following figure.

Figure 2.10 Wall Mount Installation

13. Once the device is installed on the wall, tighten the screws to secure the device.

2.2.2 Serial Connection
EKI-1528 Series provides eight ports DB9 (male) connectors. RS-232/422/485 pin
assignments as below:

Figure 2.11 DB9 Pin Assignment

2

2

1

Pin 1 2 3 4 5 6 7 8 9

RS-232 DCD RX TX DTR GND DSR RTS CTS RI

RS-422 TX- TX+ GND RX+ RX-

RS-485 DATA- DATA+ GND

1

96

5
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2.2.3 Power Connection

2.2.3.1 Overview

The EKI-1528 Series supports dual 12 to 48 VDC power inputs and power-fail relay
output.

The following figure illustrates a P-Fail alarm application example. The P-Fail alarm
contacts are visible on the front view of the terminal block.

Figure 2.12 P-Fail Alarm Application Wiring

You can connect an alarm indicator, buzzer or other signaling equipment through the
relay output. The relay opens if power input 1 or 2 fails. In a wiring example where an
LED is connected to the relay output, the LED would be off in an Open state.

Warning! Power down and disconnect the power cord before servicing or wiring 
the serial device server.

Caution! Do not disconnect modules or cabling unless the power is first switched 
off. 

The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the serial device server.

Caution! Disconnect the power cord before installation or cable wiring. 

Load
External 
Power

24Vdc, 1A ResistanceTerminal Block Front View for 
P-Fail Alarm Contacts
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2.3 Installing the Configuration Utility

1. Insert the Advantech EKI Device Configuration Utility CD-ROM into the CD-
ROM drive (whereas E:\ is the drive name of your CD-ROM) on the host PC.

2. Use Windows explorer or the Windows Run command to execute the setup pro-
gram, the path for the setup program on the CD-ROM is as follows:
E:\EKI_Device_Configuration_Utility_v2.01.exe

3. If there is an existing COM port mapping utility on the host PC, remove it at this 
time. A system reboot may be necessary before continuing the installation.

4. Once the InstallShield Wizard screen displays, click Next to proceed with the 
installation.

Figure 2.13 InstallShield Wizard 1 of 4

Note! Microsoft .NET Framework version 2.0 or greater is required for this 
application.
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5. The Software License Agreement displays, press I Agree to continue or Cancel 
to stop the installation.

Figure 2.14 InstallShield Wizard 2 of 4

The InstallShield continues and a status screen displays. The default installation
path is C:\Program Files\EKI Device Configuration Utility.

Figure 2.15 InstallShield Wizard 3 of 4
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6. Once the installation of the package is finished a Configuration Utility Setup 
screen displays. Click Finish to conclude the process and exit the InstallShield 
Wizard.

Figure 2.16 InstallShield Wizard 4 of 4
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Chapter 3

3Utility Configuration



3.1 Configuration Utility Overview
Advantech EKI series serial device servers provide an easy-to-use utility to configure
your serial device server through an Ethernet connection. For secure administration,
it can also restrict the access rights for configuration to only one host PC. With this
secure function enabled, other PCs will not have permission for configuration. After
the installation program on the Advantech EKI Series Driver Utility CD-ROM is fin-
ished, the serial device servers are ready for use and configuration.

Advantech Serial Device Server Configuration Utility is an excellent device server
management tool. You can connect and configure the local and remote Advantech
serial device servers easily. The utility provides access to the following functions:

 Configure the network settings (you can set the IP address, Gateway address, 
and Subnet mask)

 View and set the serial port parameters (configure operating mode, baud rate, 
serial port settings and operating mode settings)

 Perform diagnostic tests (virtual COM port testing, port status list)
 Perform administrative functions (export and import the serial device server set-

ting, manage access IP, a descriptive name, upgrade firmware)

3.2 Menu Bar
You can open the Advantech EKI Device Configuration Utility from the Windows Start
Menu by clicking Start > All Programs > EKI Device Configuration Utility >
Advantech EKI Device Configuration Utility. The Configuration Utility displays as
follows. 

For the purposes of this manual, the user interface is separated into six sections.

Figure 3.1 Configuration Utility Overview

5

4

3

2

6

1
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3.3 Quick Tool Bar
The Advantech EKI Device Configuration Utility makes use of a Quick Tool Bar menu
to allow quick access to the management functions. See the following figure for fur-
ther information.

Figure 3.2 Quick Tool Bar Overview

No Item Description

1 Menu Bar Displays File, View, Management, Tools and Help.

2 Quick Tool Bar Useful management functions shortcuts.

3 Serial Device Server 
List Area

Available devices are listed in this area. Devices and COM ports 
can be organized or grouped in this area. 

4 Information Panel Click on the devices or move cursor to the devices, the related 
information is shown in this area.

5 Status Bar Displays the current time.

6 Configuration Area Click on the item on the Device Server List Area, the configura-
tion page displays. 

Note! The configuration utility makes use of TCP/UDP ports 5048 and 5058 to 
communicate with the Advantech EKI serial device server. T

Please reserve TCP/UDP port 5048 and 5058 in your Ethernet network, 
configuration utility will use these ports to communicate with Advantech 
EKI-1000, ADAM-4570, and EDG-4500 serial device servers.

Icon Item Description

Utility Settings Clear to configure the general settings for the Main Form 
Setting and Device Manager menus.
 Refer to “Utility Settings” on page 20.

Configuration Wizard Start the software wizard (setup assistant) to lead you 
through the VCOM configuration process for device 
server product.

Clear Device List and 
Search Again

Click to clear listed device servers in the Serial Device 
Server List Area and initiate a new search.

NOTE: A continuous click of the icon results in the 
following message: Please do not refresh so fre-
quently.

Search Again Click to search for serial device servers on the local 
LAN.
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3.3.1 Utility Settings

3.3.1.1 Main Form Setting
Click View > Settings to configure utility settings.

Figure 3.3 View > Settings > Main Form Setting

Add IP Address to 
Favorite

Click to include the selected IP Address into the Favor-
ites list group.

Search for a Range 
of IP Addresses

Click to begin a range search. Enter the beginning and 
ending IP addressed to being a search within the string 
parameters. 

Manual Direct Map-
ping Virtual COM 
Port

Click to add a target by selecting the Device Type and 
inputting the IP address without physically connecting 
the serial device server to the network.

Icon Item Description

Item Description

Main Window Settings

Maximum Main Window 
On Load

Check the box to enable the limiting of main windows on-load to 
the maximum value.

Log Settings

Show Log Message Win-
dow

Check the check box to activate the AdvLogMessage form. The 
Form Log message displays. 

Save Log to File Check the check box to save log to file.

Browse If the Save Log to File option is enabled, click Browse to select a 
file to save log data. 

Language Settings

Interface Language Click the drop-down menu to select an interface language: Tradi-
tional Chinese, Simplified Chinese or English.

NOTE: A restart is required for the settings to take effect.
OK Click OK to save and exit the Utility Settings menu.

Cancel Click Cancel to discard the changes.
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Device Manager

Figure 3.4 View > Settings > Device Manager

Apply Click Apply to save the main form settings.

Item Description

Item Description

Device Manager

Tree View Grouping Click the drop-down menu to enable or disable grouping.

Show Empty Device Type 
Node

Check the check box to show empty device type node or not.

Expand New Appended 
Device Node

Check the check box to expand a new appended device node.

Device Auto Detection

After utility ready, start 
auto detection after X sec-
ond

Enter a value to specify the time to auto detection time (-1 
means disable auto detection).

Auto detect devices every 
X second

Enter a value to specify the time to auto detect devices.

Check device alive every 
X second

Enter a value to specify the time to check device alive.

Mark device as lost con-
tact after retry for X times

Enter a value to specify the time to mark device as lost contact.

Unsigned Hardware Installation

Automatic answer for 
unsigned hardware instal-
lation

Check the check box to enable or disable answer automatically 
for unsigned hardware installation.

OK Click OK to save and exit the utility setting.

Cancel Click Cancel to discard the changes.

Apply Click Apply to save the utility setting.
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3.3.2 Discovering Your Device Server

3.3.2.1 Auto Searching
Advantech EKI Serial Device Server Configuration Utility 2.01 or higher will automati-
cally search all the EKI-15xx(-DR) series serial device servers on the network and
show them on the Serial Device Server List Area of the utility. The utility provides an
auto-search function to show your device (s) by simply executing the configuration
utility program from the Start Menu.

From here all devices on the same network domain will be searched and display on
Device Server List Area. You can click on the device name to show the features of
the specific device. Click on the “+” before the model name, and the utility will expand
the tree structure to show the individual device name. Click on the “-” before the
model name, and the utility will collapse the tree structure.

Figure 3.5 Open View of Serial Device Configuration Utility

In the previous figure, the EKI-1528 serial device servers is listed as EKI-1528-DR-
AE-C52801.

Select the device in this sub-tree. The first tab on the Configuration Area shows the
summary of “Basic Information” included device type, version, and name, “Ethernet

Note! When you run the configuration utility for the first time, the default device 
name is obtained from the serial device’s MAC identification number. 
The name can be altered through the configuration utility.
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Information”, and “Serial Port Information”. In the serial port information frame, it dis-
plays the operation mode, status and connected host IP.

Figure 3.6 Selecting a Group

Click on the “+” before the device name, and the utility will expand the interfaces on
this device server.

Figure 3.7 Selecting a Device
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Click on each item to enter the configuration page to change the setting. The configu-
ration will be introduced on following sections.

Figure 3.8 Viewing Basic Settings

3.3.3 Network Settings
Prior to setting up the server’s IP address determine the IP address mode.

There are four mode types available:

 Static IP: mode to assign a specific assigned address
 DHCP / AutoIP: mode to automatically assign IP addresses through a DHCP 

server
 BOOTP / AutoIP: mode to automatically assign an IP address through the con-

figuration server
 DHCP/BOOTP/AutoIP: mode to automatically assign an IP address using a 

Bootstrap Protocol or DHCP server.
The server is set with the following default IP configuration:

10.0.0.1 (Eth1)

10.0.0.2 (Eth2)

The EKI series includes a software utility option, which you can install on your sys-
tem, for configuration through computer-based software. The EKI series also
includes a web interface option for configuration through a standard web browser.
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You can choose from four possible IP Configuration modes --- Static, DHCP, BOOTP,
and DHCP/BOOTP.

Figure 3.9 Network Settings Overview

Click Reboot to reboot the serial device server. Any configuration changes you have
made since the last time you issued a save will be lost.

To reset the device:

1. Right-click a desired device to display the settings menu.

Item Description

Static IP Static IPUser defined IP address, Subnet Mask, and Default 
Gateway.

DHCP + Auto-IP DHCP Server assigned IP address, Subnet Mask, Default Gate-
way, and DNS.

BOOTP + Auto-IP BOOTP Server assigned IP address.

DHCP + BOOTP + Auto-IP DHCP Server assigned IP address, Subnet Mask, Default Gate-
way, and DNS, or BOOTP Server assigned IP address. (If the 
DHCP Server does not respond)

DNS Setting In order to use DNS feature, you need to set the IP address of 
the DNS server to be able to access the host with the domain 
name. The EKI serial device server provides Primary DNS 
Server and Secondary DNS Server configuration items to set the 
IP address of the DNS server. Secondary DNS Server is 
included for use when Primary DNS server is unavailable.

DHCP Advanced Setting When you enabling DHCP protocol to get IP address, it will be 
waited DHCP server to give IP within DHCP time out. The 
default value is 180 seconds.
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2. Select Reset Device.

Figure 3.10 Reset Device

3.4 Administrator Settings

3.4.1 Locate the Serial Device Server
When several serial device servers are connected to the network, identification of a
specific serial device is possible through the Locate function. 

To locate the serial device server:

1. From the device list frame, locate the desired device and right-click on it to dis-
play the settings menu.
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2. Select Locate from the menu.

Figure 3.11 Locate the Serial Device Server

The unit’s Status LED will turn solid amber and the buzzer will make a beep sound
until you click Stop Locate.

3.4.2 Lock/Unlock the Serial Device Server (Password Protection)
The configuration utility provides the "Lock Device" function to make it more secure.
You need to set up a password the first time, by clicking "Lock Device". 

3.4.2.1 Lock the Serial Device Server
The configuration utility provides the "Lock Device" function to make it more secure.

To lock the serial device server:

1. Right-click the device to extend the administrator setting.
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2. Select Lock Device.

Figure 3.12 Lock the Serial Device Server

3. Enter a password and re-confirm the profile password.

Figure 3.13 Enter a Password

4. After re-confirming the password, the serial device server will reboot automati-
cally and store your password in the memory.
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3.4.2.2 Unlock the Serial Device Server
If you want to disable this function or change the password, click "Change Password"
to change the password to default "None" (leave the new password and confirm new
password columns blank). The serial device server will restart and store the new
password in the memory.

Figure 3.14 Unlock the Serial Device Server

3.4.3 Change Password
To unlock the serial device server:

1. Right-click a desired device to display the settings menu.
2. Select Change Password.

Figure 3.15 Change Password

3. Right-click a desired device to display the settings menu. Select Reset Device 
to restart the serial device server and store the new password in the memory.
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3.4.4 Restore to Factory Default Settings
The configuration utility provides this function to restore the serial device server to
factory default settings. The confirm message will display when you click Restore to
Factory Default Settings. If you really want to restore the serial device sever to fac-
tory default settings, click “Yes” to continue.

The serial device server will power off within ten seconds. After power is restored, all
settings will be reset to the factory defaults. If the power remains on for more than ten
seconds, the serial device server will not be changed.

3.4.5 Resetting the Device
The Reset Device allows you to reset the serial device server. The function discon-
nects both the ethernet and serial connections.

The function also allows the serial device server to save new configuration settings to
flash memory. Once a new setting is changed, you can use the Save function to
accept the changes. Then, you will need to initiate a reset function to save the set-
tings to flash memory. 

From the To access this page, click Tools > Reboot.

Click Reboot to reboot the serial device server. Any configuration changes you have
made since the last time you saved will be lost.

To reset the device:

1. Right-click a desired device to display the settings menu.
2. Select Reset Device.

Figure 3.16 Change Password

The device initiates a reset function. Once the process is complete, the serial device
server displays under the Serial Device Server listing once again.
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3.4.6 Add to Favorite
The Add to Favorite function allows to easily map available devices to Favorite’s. By
bookmarking specific devices, you can create quickly accessible shortcuts for exist-
ing critical devices from the vast pool of locally or remotely networked EKI devices.

3.4.7 Auto Mapping
See “Auto Mapping” on page 42 for further details.

3.4.8 Manual Mapping
See “Manual Mapping” on page 43 for further details.

3.4.9 Update Firmware
Advantech continually upgrades its firmware to keep up with the ever-expending
world of computing. You can use the update firmware function in the utility to carry
out the upgrade procedure. Please access Advantech’s website: http://www.advan-
tech.com to download the latest version of the firmware. Before update the firmware,
make sure that your host’s Network domain is as same as the serial device server or
the host can establish the TCP connection to the serial device server.

To update firmware:

1. Right-click a desired device to display the settings menu.
2. Select Update Firmware.

Figure 3.17 Update Firmware

3. Select the firmware file you want to update.
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Wait for few seconds to process the updating firmware. After downloading the firm-
ware completely, click on the OK button. The serial device server will restart automat-
ically.

Note! Be sure that the host PC Ethernet network domain is as same as the 
EKI-1528 Series serial device server or the host PC can establish the 
TCP connection with the serial device server while doing the updating 
firmware process.
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4Selecting an 
Operating Mode



4.1 Overview
The EKI-1528 is designed to network-enable any RS-232/422/485 serial device, and
provides industry-grade hardware and easy-to-use software to make connecting
serial devices to an Ethernet network a surprisingly simple process.

These units immediately upgrade your existing serial devices for integration into the
Internet world. The EKI-1528 features many powerful functions, such as high speed
data transfer, access-control, auto-detection of all EKI series products, and more.

After the simple installation steps to attach your network and serial device to the
appropriate connectors on the serial device servers and driver installation, you will be
able to communicate with the serial devices via its own application software and wit
the EKI serial device server. COM port redirector, USDG TCP server mode, TCP cli-
ent mode, UDP server mode, UDP client mode, RFC2217 mode are all different
methods of making a serial connection across using one or more serial device serv-
ers.

4.2 COM Port Redirector (Virtual COM Port)
Advantech EKI Device Configuration Utility is a serial COM port redirector that cre-
ates virtual COM ports and provides access to serial device connected to Advantech
serial device server. You can configure the serial device server and enable the Virtual
COM port using one integrated utility. Advantech EKI Device Configuration Utility-
allows you to configure Microsoft applications to communicate with network enabled
serial device servers as easily as if they were physically installed in or directly con-
nected on the PC. 

The Advantech redirector can create up to 255 virtual COM ports. Application on the
host can open virtual COM port to access the serial device servers at the same time.
The redirector will handle each active virtual COM port as a separate TCP connec-
tion to Advantech serial device servers.

Figure 4.1 Virtual COM Mode

The EKI-1528 Series provides Multi-access function through an Ethernet connection
path, allowing a maximum of five connections to open one serial port simultaneously.
In this mode, all connections use the same serial setting. If one serial setting within
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this configuration is configured differently, the data communication will not function
correctly.

Figure 4.2 Configuring Virtual COM Mode

The Host Idle Timeout setting monitors the connection between the host and the
device. If the Host Idle Timeout setting time is reached, the device server will release
the resources allocated to the port mapping. This prevents a stalled host from affect-
ing the connective device.

The Multi-access function has two modes. One is Normal mode and the other is
Round-Robin mode.

4.2.1 Normal mode
By disabling the Response Timeout parameter, the EKI-1528 Series will operate in
normal mode. When multiple hosts simultaneously open the serial port, only the first
connected host has management control; the remaining connections only have a
data communication function. Each serial port supports up to five simultaneous con-
nections, so multiple hosts can transmit/receive data to/from the same serial port
simultaneously. Every host can transmit data to the same serial port, and the EKI-
1528 Series will also transmit data to every hosts. When the multiple hosts transmit
data to the same serial port at the same time, the received data from Ethernet and
the outputs of serial port are mixed. When the EKI-1528 Series receives data from
serial port, the data will also be transmitted to the connected hosts simultaneously.

4.2.2 Round-Robin mode
By enabling the Response Timeout parameter, the EKI-1528 Series operates in
“Round-Robin mode”. Each serial port supports up to five simultaneous connections
allowing hosts to simultaneously transmit/receive data to/from the same serial port.
Every host can simultaneously transmit data to the same serial port, EKI-1528 Series
processes the data in the order arrived. The EKI-1528 Series processes the first
host’s request and replies. The serial device server determines the end of the serial
acknowledgement through a response timeout. When EKI-1528 serial device server
does not receive a response from the serial port after a response timeout query, the
device replies with an acknowledgement and then processes the next host request. 

With an increased number of hosts, response time may be lengthy, increasing the
period of the Response Timeout. Frame Break is therefore an important parameter
for Round Robin mode. The parameter is a smart method of reducing ineffective wait-
ing periods and streamlining the transmission process. 

By disabling the Frame Break function, EKI-1528 Series devices will wait for a
“Response Timeout” period, whether or not the device has transmitted data. During
this period, the host commands are queued and processed in the order received. 

If Frame Break is enabled, the serial port idle is longer than the Frame Break period.
The EKI-1528 Series assumes the communication is completed and continues with
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the next query. This is an efficient way to reduce waiting time and improve perfor-
mance.

4.3 USDG Data Mode
The EKI-1528 Series can function either as Data server or Data client. Both opera-
tions support TCP and UDP protocols. The EKI-1528 Series allows you to treat your
serial devices as if they were networking devices. You can issue commands or trans-
mit data from serial devices, connected to a EKI-1528 Series device, to any devices
that are connected to the Internet.

4.3.1 USDG TCP Client Mode
In TCP Client mode, the TCP connection is established from the EKI serial device
server. This operation mode supports a maximum of 16 simultaneous connections for
each serial port on EKI-152X series to one host or several hosts. You can configure
the IP address and TCP port number of the network hosts connected to the EKI serial
device server using the Advantech Serial Device Server Configuration Utility. After
configuring the devices, when the EKI serial device server receives the data from the
serial port, and the device server connects to the hosts which are configured.

Figure 4.3 USDG TCP Client Mode

In USDG Data TCP Client mode, you may need to enable the peer numbers you
would like to receive. You can set a maximum sixteen network devices to which you
may connect. You need to fill out the IP Address and Port (including local port and
peer port) of each network device to which you want to connect. 
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In the Peer for Receiving Data menu, entering “0” as the value for the Local Port will
assign a random TCP Port for an EKI device.

Figure 4.4 Peer for Receiving Data

4.3.2 USDG Data TCP Server Mode
In TCP server mode, the TCP connection is initiated from the host to the EKI serial
device server. This operation mode supports a maximum of five simultaneous con-
nections for each serial port on an EKI serial device server from a single or multiple
hosts. However a multi-host connection simultaneously transmits the data from a sin-
gle serial port.

Figure 4.5 USDG TCP Server Mode

Figure 4.6 USDG Data Mode
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4.3.3 USDG Data UDP Client/Server Mode
The USDG UDP mode is primarily used for the broadcasting of messages over a net-
work. In UDP server mode, data is transmitted from the Host connected tothe EKI-
1528 Series USDG UDP Port (Default Port 5300). In the default UDP client mode,
EKI serial device servers simultaneously transmits UDP messages to a maximum of
16 peers.

USDG Data mode supports Data Idle Timeout, Data Listen Port, and Command Lis-
ten Port parameters.

4.3.3.1 Data Idle Timeout
The default is 60 seconds. If you want to keep connection continually, you can dias-
ble the Data Idle Timeout. Data idle Time is the time period for which the device waits
for data. If the EKI-1528 Series does not receive data during established idle time,
the EKI-1528 Series will disconnect temporarily. When the data comes in, it will
reconnect automatically. Users do not need to reconnect.

4.3.3.2 Data Listen Port
The TCP/UDP port number represents the source port number, and the number is
used to identify the channel for remote initiating connections. The port range is 1024-
65533. If an unknown caller wants to connect to the system and request services,
they must define the TCP/UDP port to carry a long-term conversation. 

Each node on a TCP/IP network has an IP address, and each IP address can allow
connection on one or more TCP port. The well-known TCP ports are those that have
been defined; for example, port 23 is used for Telnet connections. There are also
custom sockets that users and developers define for their specific needs. The default
TCP/UDP port of the EKI-1528 Port1 is 5300, Port2 is 5301, etc. Users can adjust
them according to preference or application. Each port has its own data listen port to
accept the connection requests of other network device. The data listen port cannot
be set to the same value. You can transmit/receive data to/from devices via the data
listen port. 

4.3.3.3 Command Listen Port
Each port has its own command listen port to accept connected request of other net-
work device, so the command listen port cannot be set to the same value. The Com-
mand Listen Port is different from the Data Listen port.

4.4 USDG Control Mode
In controlling mode, the EKI serial device server presents a modem interface to the
attached serial device: it accepts AT-style modem commands to connect / disconnect
to other networking device. 
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If you want a serial device running application program to connect/disconnect to dif-
ferent devices on request, this function is available through the USDG Control mode.

Figure 4.7 USDG Control Mode

Please refer to the USDG TCP/UDP server operating mode to setup the Data Listen
Port, Command Listen Port, and Data Idle Timeout.

4.4.1 Hangup Character
The default character is “+”. After you have connected to another serial device an via
EKI device, you may need to disconnect, using the command “+++”. To do this, press
“+” three times and wait for the idle timeout <default value is 100ms>; the device will
disconnect. You can set “Guard Time” to define the idle time.

4.4.2 Guard Time
The default value is 1000 ms. 

Example: <Guard Time>+++<Guard Time> 

Control Mode is designed for use with legacy operating systems, such as MSDOS,
that do not support TCP/IP Ethernet. By connecting one of the EKI’s serial ports to
the MS-DOS computer’s serial port, it is possible to use legacy software originally
designed to transmit data via modem, but now transmitting data over the Ethernet. 

Command Function

ATD <IP address><TCP 
port><CR>

Forms a TCP connection to the specified host.
Ex: ATDT 192.0.55.22:5201
In above example, the EKI serial device server forms a 
raw TCP connection to the networking device 
(192.0.55.22). The TCP port is 5201.

ATA <CR> Answering an incoming call

+++<CR> Returns the user to the command prompt when entered 
from the serial port during a remote host connection.

<LF><CR> OK <LF><CR> Commands are executed correctly

<LF><CR> CONNECT <LF><CR> Connect to other device

<LF><CR> RING ddd.ddd.ddd 
<LF>< CR>

Detect the connection request from other device, which 
IP address is ddd.ddd.ddd.ddd.

<LF><CR> DISCONNECT 
<LF><CR>

Disconnect from other device
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4.5 RFC2217 Mode
RFC2217 mode is similar to virtual COM mode in that a driver is used to establish a
transparent connection between a host computer and a serial device by mapping the
serial port on EKI-1528 Series devices to a local COM port on a host computer.
RFC2217 defines general COM port control options based on the Telnet protocol.
Third party drivers supporting RFC2217 are widely available on the Internet and can
be used to implement virtual COM mapping to the serial port of your device.

<LF><CR> ERROR <LF><CR> Incorrect commands

<LF><CR> FAIL <LF><CR> If you issue an ATDT command and can not connect to 
the device, it will response “FAIL”.

Command Function
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5.1 Setting COM Redirector
Advantech COM port mapping software is a serial COM port redirector that creates
virtual COM ports and provides access to serial devices connected to an Advantech
serial device servers. Your serial device applications can communicate with serial
devices connected to the Advantech serial device servers without software changes. 

Since the virtual COM ports work like standard Windows COM ports, your application
software sees no difference between a local serial device and one connected to an
Advantech serial device server.

The COM redirector utility and the virtual COM port management utility are integrated
into one utility with same GUI. The Advantech EKI Device Configuration Utility can
create all Virtual COM ports using the Auto Mapping function or by using the manual
mapping function.

5.2 Virtual COM Port Mapping

5.2.1 Auto Mapping
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utilityto open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. Select the target device and right-click on it to open up the options menu win-
dow.

4. Locate Auto Mapping and select it. 

Figure 5.1 Selecting Auto Mapping

The Batch Automatic Mapping Virtual COM Port window displays.

5. Locate From System Port and click the drop-down menu to select the target 
COM port.
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6. From the network address list, select the address options to map.
The selected address displays the Device Port and (EKI serial device server physical
serial port) and the system port which will be the VCOM port for the PC.

Figure 5.2 Selecting Auto Mapping 

7. From the network address list, select the address options to map.
8. Click Map Selected Ports to set the configuration.

Figure 5.3 Mapping Selected Ports

Once the mapping function is initialized, a successful mapping process results in the
virtual mapping of the designated physical serial port and VCOM PC port. See the
following figure.

Figure 5.4 Viewing VCOM Mapping Results

5.2.2 Manual Mapping
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utilityto open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. Select the target device and right-click on it to open up the options menu win-
dow.

System

Device Port

Selected
Options
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4. Locate Manual Mapping and select it. 

Figure 5.5 Selecting Manual Mapping

The Manual Mapping Virtual COM Port window displays.

5. In the Device > Serial Port drop-down menu, select the target port to map. 
This is the physical serial port on the EKI device. 

6. In the Host > COM Port drop-down menu, select the target COM port to map. 
This is the virtual port on the target PC.

Figure 5.6 Selecting Manual Mapping

7. Click Map it to continue the process. The mapping process may require a short 
time. Once this step is completed, the Manual Mapping Virtual COM Port win-
dow displays again to map the VCOM port on the target PC.

VCOM 
PC Port

EKI 
Physical
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Once the mapping function is initialized, a successful mapping process results in the
virtual mapping of the designated physical serial port and VCOM PC port. See the
following figure.

Figure 5.7 Viewing Manual VCOM Mapping Results

To allow for an automatic connection after a reboot or a power up, click the Auto
Reconnect option to enable this function.

5.2.3 Configuration Wizard
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utilityto open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. From the tool bar, select Configuration Wizard. 

Figure 5.8 Selecting the Configuration Wizard

The Wizard screen displays and lists available devices.

4. Select the target device and click Next to continue.
The Wizard Device Settings window displays.

5. Under Serial Port Settings, click the Type drop-down menu and select the port 
type.

Review the settings under the Ethernet fields and verify them.

6. Click Next to continue or Previous to return to the previous screen.
The selected settings are displayed in the following Wizard window.
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7. Locate the radio button correlating to the target port to modify and click on it to 
select it.

Verify the Device Port (EKI device physical serial port) and System Port (virtual COM
port for PC) settings before continuing. 

8. Click Finish to complete the process. A Wizard complete! screen displays indi-
cating the completion of a successful procedure.

5.2.4 Confirming Virtual COM Settings
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utilityto open the 
utility.

2. Locate Serial Ports menu in the menu pane and click on the Expand icon next 
to Virtual COM Ports to view a list of the mapped ports.

3. Select a VCOM port to view its settings.

Figure 5.9 Serial Port Listing on EKI Device

For the next step, you will need to open the device manager on your system. Using
the Device Manager, you can both view and change the COM port settings. 

4. On your desktop, click on the Start button and then on Control Panel. A win-
dow displays showing all the available control panels.

5. Click on Hardware and Sound (Hardware). A list of all available hardware con-
figuration options displays. 

6. Under Devices and Printers, click on the Device Manager link. A new window 
displays showing a list of all the available devices on your computer.

7. Locate Ports (COM & LPT) and click on the expand icon. A list of all available 
serial and parallel port devices display. 

Note! The following instructions are written for Windows 7; the Windows XP 
equivalent is displayed in parentheses (). The instructions may vary on 
other operating systems.
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The newly mapped VCOM port should be listed under the same mapped settings
used in the previous steps. 

Figure 5.10 System Port VCOM Mapping Configuration

The newly mapped VCOM port is listed under the same mapped settings used in the
previous steps. The settings correspond to the VCOM port configuration on the EKI
device, see the following figure. 

Figure 5.11 Verifying VCOM Mapping Configuration

If the settings do not correspond, the VCOM mapping is not correct. See “Virtual
COM Port Mapping” on page 42 to re-map the VCOM ports.
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5.2.5 Removing VCOM Ports
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utilityto open the 
utility.

2. Under Serial Ports, click the expand icon on Virtual COM Ports to view the con-
figured port list.

3. Locate the port to remove and right-click on it to open the options menu.
4. Scroll down to Remove This Port and click on it to initiate the procedure.

Figure 5.12 Accessing the Web Page through the EKI Device Configuration 
Utility

A Remove Port confirmation window displays.

5. Click OK to continue with the removal process or Cancel to return to the previ-
ous menu.

Once the procedure is completed, a prompt displays the successful removal of the
port from the VCOM mapping list.

5.2.6 Exporting and Importing VCOM Mapping
Importing and exporting Virtual COM Port Mapping is useful when the factory has
already used a number of serial device servers in VCOM mode. You can easily
upgrade to a new utility, and don’t need to re-map the Virtual COM Ports. For exam-
ple, when you would like to upgrade from Utility 1.71 to Utility 2.01, you can export
your own mapped Virtual COM Ports in Utility 1.71 and save them as a *.cpm file.
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After upgrading to Utility 2.01, import your *.cpm file and restore your own Virtual
COM Ports.

Figure 5.13 Importing/Exporting Virtual COM Port Mapping

5.3 Running a Diagnostic Test
The purpose of this test is to ensure the communication from the host PC to the EKI-
1528 is ok. If there is an error, you can also check the communication between the
EKI-1528 and other devices.

When this menu option is selected, an external test will be run to check that the con-
nection signals for each port are working properly. For the test, you will need to con-
nect each port to a loopback tester (provided in the package). The loopback test only
applies to RS-232 mode. The test is divided into two parts: Signal test and Communi-
cation Parameters test.

Note! This Virtual COM Port Mapping tool can only recover Virtual COM Ports 
that have been mapped previously. For newly installed serial device 
servers, please follow the virtual COM Port mapping steps.

Note! Before running a diagnostic test, you need to map the virtual COM ports.
49 EKI-1528-DR Series User Manual



1.  Click Simple Serial Test in the Tools menu.

Figure 5.14 Running a Diagnostic Test
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Chapter 6

6Web Configuration



6.1 Overview
EKI-1528 Series serial device server can be configured through a web interface. By
using a standard web browser, the same procedure as with the Windows configura-
tion utility can be used. In the browser’s address field, enter the IP Address of your
EKI-1528 Series serial device server. The default IP setting is 10.0.0.1, but you
should use the IP which you have previously assigned for this device. Once the IP is
entered, you will be presented with the following windows.

6.2 Accessing the Web Page

6.2.1 Accessing the Web Page via Configuration Utility
To access the web page via configuration utility:

1. Select Ethernet under the desired device.
2. Click Launch Browser.

Figure 6.1 Accessing the Web Page via Configuration Utility

Note! Before using the web-based configuration, make sure your host PC 
Ethernet network IP domain is as same as the serial device server, or it 
can establish the TCP connection with the serial device server.

Note! It is recommended that you use Microsoft Internet Explorer 7.0 or 
higher.
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6.2.2 Accessing the Web Page via Web Browser
Once the device is installed and connected, power on the device. The following infor-
mation guides you through the logging in process.

1. Launch your web browser on the PC.
2. In the browser’s address bar, type the device’s default IP address (10.0.0.1 

(Eth1) and 10.0.0.2 (Eth2)).
The main interface displays.

6.3 System
You can change the Device Name and Device Description on this page. You can also
enable or disable the Telnet and SNMP functions. Moreover, you can set the Time-
zone related settings.

To access this page, click System.

Figure 6.2 System

The following table describes the items in the previous figure.

Item Description

Firmware version Displays the current firmware version of the device.

Revision number Displays the revision number of the device.

Device Name Enter the device name: up to 31 alphanumeric characters.

Device Description Enter the device description.

Telnet Click Enabled or Disabled to set remote access through the Telnet 
Service function.

SNMP Click Enabled or Disabled to define the SNMP daemon.

Local Time Click Modify to set local date and time of the system.

Time Server Enter the address of the SNTP server. This is a text string of up to 64 
characters containing the encoded unicast IP address or hostname of 
a SNTP server. Unicast SNTP requests will be sent to this address. If 
this address is a DNS hostname, then that hostname should be 
resolved into an IP address each time a SNTP request is sent to it.

Save Click Save to save the values and update the screen.
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6.4 Ethernet Configuration
Choose either Eth 1 or Eth 2 in the Ethernet Configuration page.Enter the corre-
sponding values for your network environment. Remember press Save after fill in all
values.

To access this page, click Ethernet Configuration.

Figure 6.3 Ethernet Configuration

The following table describes the items in the previous figure.

Item Description

IPv4 Configuration

Mode Click the drop-down menu to select the IP Address Setting mode: 
Static IP, DHCP, or BOOTP.

MAC Address Enter the MAC address to which packets are statically forwarded.

IP Address Enter a value to specify the IP address of the interface. The default is 
10.0.0.1 (Eth1) & (0.0.0.2 (Eth2).

Subnet Mask Enter a value to specify the IP subnet mask for the interface. The 
default is 255.0.0.0.

Default Gateway Enter a value to specify the default gateway for the interface.

DNS Configuration

DNS Click the radio button to select the DNS mode: Automatic or Specific.

Current Status

IP 1 Displays the current IP address 1 of the device.

IP 2 Displays the current IP address 2 of the device.

Save Click Save to save the values and update the screen.
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6.5 Port Configuration
There are Basic, Operation Mode, and Advanced Setting in the serial port configura-
tion. For more detailed information for setting.

6.5.1 Basic
The Basic menu allows for the configuration of the serial interface type, baud rate,
parity, data / stop bits, and flow control for port configuration.

To access this page, click Port Configuration > Basic.

Figure 6.4 Port Configuration > Basic

The following table describes the items in the previous figure.

6.5.2 Operation
The Operation menu allows for the configuration of the mode type and related attri-
butes for port configuration.

Note! All new configurations will take effect after rebooting. To reboot the 
device, click Tools > Reboot.

Item Description

Type Click the drop-down menu to select a serial interface: RS-232, RS-422 
or RS-485.

Baud Rate Enter a value to specify the baud rate. The value should conform to the 
current transmission speeds of connected devices when setting the 
baud rate.

Parity Click the drop-down menu to select the parity: None, Odd, Even, Mark 
or Space.

Data Bits Click the drop-down menu to select the data bits: 5, 6, 7, or 8.

Stop Bits Click the drop-down menu to select the stop bits: 1, 1.5 or 2.

Flow Control Click the drop-down menu to select the flow control mode: None, XOn/
XOff, RTS/CTS or DTR/DSR

Save Click Save to save the values and update the screen.
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To access this page, click Port Configuration > Operation.

Figure 6.5 Port Configuration > Operation

The following table describes the items in the previous figure.

Item Description

Mode Click the drop-down menu to select the port configuration mode: Vir-
tual COM Mode, USDG Data Mode, USDG Control Mode or RFC2217 
Mode.

Virtual COM Mode

Host Idle Timeout (s) Enter a value to define the host idle timeout period.

Response Timeout 
(ms)

Enter a value to define the response timeout period.

Frame Break (ms) Enter a value to specify the frame break time.

Pack conditions (Pack sent immediately when reach 1024 Bytes)

By size Click the option to send pack immediately by size.

By interval Click the option to send pack immediately by interval.

By end-character Click the option to send pack immediately by end-character.

Port Data Buffering

Port Data Buffering Click the drop-down menu to select port data buffering type: None or 
RAM.

When Data Full Click the drop-down menu to select process mode when data full: 
Stop.

USDG Data Mode
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6.5.3 Advanced
The Advanced menu allows for the configuration of the time delay, buffer data size
and FIFO size for port configuration.

Protocol Click the drop-down menu to select the protocol: TCP or UDP.

Data Idle Timeout 
(s)

Enter a value to define the data idle timeout period.

Data Listen Port Enter a value to identify the channel for remote initiating connections.

Command Listen 
Port

Enter a value to identify the command listen port for accepting con-
nected request of other network device.

Response Timeout 
(ms)

Enter a value to define the response timeout period.

Frame Break (ms) Enter a value to specify the frame break time.

TCP Mode Extra Options

Auto Connect To 
Peer IP

Click the option to connect to TCP/IP which are set at Peers page 
automatically after boot up.

Port Data Buffering

Media Click the drop-down menu to select port data buffering type: None or 
RAM.

When Data Full Click the drop-down menu to select process mode when data full: 
Stop.

Pack conditions (Pack sent immediately when reach 1024 Bytes)

By size Click the option to sent pack immediately by size.

By interval Click the option to sent pack immediately by interval.

By end-character Click the option to sent pack immediately by end-character.

By character-time-
out

Click the option to sent pack immediately by character-timeout.

Peer for Receiving Data

Peer Number Click the drop-down menu to select the number of network device 
which you want to connect. Maximum is 16 network devices.

USDG Control Mode

Protocol Display the current protocol of the USDG control mode.

Data Idle Timeout 
(s)

Enter a value to define the data idle timeout period.

Data Listen Port Enter a value to identify the channel for remote initiating connections.

Command Listen 
Port

Enter a value to identify the command listen port for accepting con-
nected request of other network device.

Hang up Character The default character is “+”. After you have connected to another serial 
device via an EKI device, you may need to disconnect, using the com-
mand “+++”. To do this, press “+” three times and wait for the idle time-
out <default value is 100ms>; the device will disconnect. You can set 
“Guard Time” to define the idle time.

Guard Time (ms) Enter a value to identify the guard time.

RFC2217 Mode

Listen Port Enter a value to identify the channel for remote initiating connections.

Host Idle Timeout (s) Enter a value to define the host idle timeout period.

Save Click Save to save the values and update the screen.

Item Description
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To access this page, click Port Configuration > Advanced.

Figure 6.6 Port Configuration > Advanced

The following table describes the items in the previous figure.

Item Description

Enable Delay Time Click the option to enter the value to postpone the receive data.

Ignore Purge Click the option to purge the serial port when the serial port opens first 
time.

Disable Character 
Timeout Detection

Click the option to disable the serial port character timeout detection.

Disable Multiple 
Connection

Click the option to disable the multi-access function. Then only one 
TCP connection is allowed on this serial port.

Enable BufferData 
Size

Click the option to enter the value to queue data to become a packet.

Port Timeout Settings determine the time period that received data from serial port is 
postponed. 
Click the option to enter the value to define the timeout period.

RTL Receiver Trigger Level
Click the option to determines how often or when the receiver interrupt 
is be triggered.
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6.6 Monitor
The EKI serial device server provides the function that allows monitoring of the serial
ports’ status. The serial port’s operation mode and status is available for display. The
IP address of the host PC which is communicating with serial port is also displayed. 

The Monitor function provides a method to monitor the serial device server’s status
(operation mode, baud rate, data bits, stop bits, parity and RTS/XON/DTR). 

Monitoring information is divided into three main message types: Setting/Statistic/
Connected IP. 

6.6.1 Setting
The Monitor Setting page allows for easy viewing of the port’s statistics. 

To access this page, click Monitor > Setting.

Figure 6.7 Monitor > Setting

TTL Transmitter Trigger Level
Click the option to designate to suspend or resume transmission.

FCL Flow Control Lower Trigger Levels
Click to set register for automatic flow control. FCL stores the lower 
trigger level. 

FCH Flow Control Higher Trigger Level
Click to set register for automatic flow control. FCH stores the upper 
trigger level. 

Write to FIFO Size Click the option to determines the maximum characters will be wrote 
into one interrupt.

USDG Advanced Options (Flow Control will overwrite these options)

RTS Control Click the drop-down menu to select the status of RTS: ON, OFF, Tog-
gle By Connect or Toggle By Data.

DTR Control Click the drop-down menu to select the status of DTR: ON, OFF, Tog-
gle By Connect or Toggle By Data.

Save Click Save to save the values and update the screen.

Item Description
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The following table describes the items in the previous figure.

6.6.2 Statistic
The Monitor Statistic page allows for easy viewing of the port’s TX/RX data count. 

To access this page, click Monitor > Statistic.

Figure 6.8 Monitor > Statistic

The following table describes the items in the previous figure.

Item Description

Operation Mode Display the current operation mode of the selected port.

Baud Rate Display the current baud rate of the selected port.

Data Bits Display the current data bits of the selected port.

Stop Bits Display the current stop bits of the selected port.

Parity Display the current parity of the selected port.

RTS/CTS Display the current RTS/CTS status of the selected port.

XON/XOFF Display the current XON/OFF status of the selected port.

DTR/DSR Display the current DTR/DSR status of the selected port.

Save Click Save to save the values and update the screen.

Item Description

Tx Count Display the current Tx count of the selected port.

Rx Count Display the current Rx count of the selected port.

Total Tx Count Display the current total Tx count of the selected port.

Total Rx Count Display the current total Rx count of the selected port.

RTS Display the current RTS status of the selected port.

CTS Display the current CTS status of the selected port.

DTR Display the current DTR status of the selected port.

DSR Display the current DSR status of the selected port.

DCD Display the current DCD status of the selected port.

Save Click Save to save the values and update the screen.
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6.6.3 Connected IP
The Monitor Connected IP page allows for easy viewing of all connected device’s IP
address. 

To access this page, click Monitor > Connected IP.

Figure 6.9 Monitor > Connected IP

The displayed attributes are not configurable in this menu, and are for information
purposes only.

6.7 Alert
On the Alert Settings page, you may configure how administrators are notified by ce
tain system, network, configuration, power, and cellular connection events. Rely on
the events, administrators can collect different options for automatic notification. Mail
refers to send an e-mail to a specified mail address. Trap refers to send an SNMP
Trap. Agent refers to send the SNMP agent setting.

Item Description

Connected IP Displays the IP designation for the device.

IP Address Displays the current connected IP address of the selected port.
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6.7.1 Setting
To access this page, click Alarm > Setting.

Figure 6.10 Alarm > Setting

The following table describes the items in the previous figure.

Item Description

Mail Server

Mail Server This field is for your mail server’s domain name or IP address.

From Email address This is the e-mail address from which automatic e-mail warnings will 
be sent.

Email addresses 1-4 This is the e-mail address or addresses to which the automatic e-mail 
warnings will be sent.

SNMP Trap Server

Trap Server Use this field to indicate the IP address to use for receiving SNMP 
traps.

Trap Server Port Enter the SNMP Trap server port.

Trap Version (default = v1): Use this field to select the SNMP trap version.

Trap Community Use this field to designate the SNMP trap community.

SNMP Agent Setting

Read Community Read community name of your agent.

Write Community Write community name of your agent.
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6.7.2 Event
In this page, you can configure events which will trigger logging or notification. You
can select three methods (Mail, SNMP, or log file) to record or send event mesages.
System event notification is available for cold start, warm start, authentication failure,
IP address/Password change, serial DCD/DSR port change and Ethernet link down
information.

Contact Identify the system contact of your agent.

Location Identify the system location of your agent.

Save Click Save to save the values and update the screen.

Item Description
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To access this page, click Alarm > Event.

Figure 6.11 Alarm > Event (1 of 2)

The following table describes the items in the previous figure.

Item Description

System Event

Cold Start Click the option to select a warning type when the device server’s 
power is cut off and reconnected.
EKI-1528-DR Series User Manual 64



 

6.8 Syslogd
The EKI serial device server provides the functionality to allow network devices to
send event messages to a logging server, also known as a Syslog server, by way of
the Syslogd function. The Syslog protocol is supported by a wide range of devices
and can be used to log different types of events.

6.8.1 Syslogd Setting
Users can enable the syslogd function to record historical events or messages locally
or on a remote syslog server.

To access this page, click Syslogd > Syslogd Setting.

Figure 6.12 Syslogd > Syslogd Setting

The following table describes the items in the previous figure.

Warm Start Click the option to select a warning type when the device server is 
reboot.

Authentication fail-
ure

Click the option to select a warning type when an incorrect password is 
entered.

IP address changed Click the option to select a warning type when the IP address is 
changed.

Password changed Click the option to select a warning type when the password is 
changed.

Ethernet1 link down Click the option to select a warning type when the Ethernet 1 port is 
disconnected.

Ethernet2 link down Click the option to select a warning type when the Ethernet 2 port is 
disconnected.

DCD changed

Port Click the option to select a warning type of the selected port when a 
change in the DCD (Data Carrier Detect) signal indicates that the 
modem connection status has changed.

DSR changed

Port Click the option to select a warning type of the selected port when a 
change in the DSR (Data Set Ready) signal indicates that the data 
communication equipment is powered off.

Save Click Save to save the values and update the screen.

Item Description

Item Description

Syslogd Click Enabled or Disabled to set the logging service status.

Save Click Save to save the values and update the screen.
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6.8.2 Syslogd Message
After enabling the syslogd function, users can check the history in the syslogd mes-
sage page.

To access this page, click Syslogd > Syslogd Message.

Figure 6.13 Syslogd > Syslogd Message

6.9 Tools
The EKI serial device server provides tools for access to ping and reset functions.

6.9.1 Ping
The ping page can help users diagnose ethernet problems. Users can use the ping
page to ask the device to ping a specific target to check the Ethernet network status.

The Ping page allows you to configure the test log page.
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To access this page, click Tools > Ping.

Figure 6.14 Tools > Ping

The following table describes the items in the previous figure.

6.9.2 Reboot
The configuration will take effect after clicking Save button. But all configurations are
saved to flash memory after a system reboot. Press the Reboot button and the sys-
tem will give a reset response. It will take a few seconds to reconnect with the new
values.

To access this page, click Tools > Reboot.

Click Reboot to reboot the serial device server. Any configuration changes you have
made since the last time you issued a save will be lost.

Item Description

IP Enter the IP address or host name of the station to ping. The initial 
value is blank. The IP Address or host name you enter is not retained 
across a power cycle. Host names are composed of series of labels 
concatenated with periods. Each label must be between 1 and 63 
characters long, maximum of 64 characters.

Size Enter the size of ping packet. The default value is 56. The value 
ranges from 8 to 5120. The size entered is not retained across a power 
cycle.

Count Enter the number of echo requests to send. The default value is 4. The 
value ranges from 1 to 5. The count entered is not retained across a 
power cycle.

Run ping Display the ping reply format.

Save Click Save to save the values and update the screen.
67 EKI-1528-DR Series User Manual



6.10 Management
The EKI serial device server allows for easy installation and maintenance and reli-
able maintenance access from anywhere. With the reliable management tools avail-
able, you can streamline staffing and troubleshooting requirements to a centralized
system. 

6.10.1 Log File
If users enable the system event or serial event to log in file, users can download the
log file from here.

To access this page, click Management > Log File.

Figure 6.15 Management > Log File

The following table describes the items in the previous figure.

6.10.2 Change Password
The Change Password function allows you to easily update your current password
from a single menu.

To access this page, click Management > Change Password.

Figure 6.16 Management > Change Password

The following table describes the items in the previous figure.

Item Description

System Log File Click the drop-down menu to select a specific action for the system log 
file. Available options: Download System Log, Remove System Log, 
Download and Remove System Log.

Save Click Save to save the values and update the screen.

Item Description

Old password Enter the old password.

New password Enter the character set for the define password type.

New password 
again

Retype the password entry to confirm the profile password.

Save Click Save to save the values and update the screen.
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If you have set a password through the configuration utility or Telnet or serial console,
when you access the web configuration, you need to key in the password. It is not
necessary to enter the user name in the dialog.

If you want to disable the password protection, change the password to default option
None (leave the new password column blank). Be sure to press the Save button and
reboot the serial device server to make the change effective.

6.10.3 Secure access IP
The Secure Access IP function allows you to assign single or multiple user access to
data transmission through a serial device server.

Access is configured as follows: Set Access IP number to 0: unrestricted access

Set Access IP number to greater than 0: restricted to listed Access IP listing.

To access this page, click Management > Secure access IP.

Figure 6.17 Management > Secure access IP

The following table describes the items in the previous figure.

6.10.4 Export Device Settings
Export the server configuration settings to a .conf file. 

To access this page, click Management > Export.

Click Export to export the serial device server settings.

6.10.5 Import Device Settings
Import the server configuration settings to a .conf file. 

To access this page, click Management > Import.

Figure 6.18 System

The following table describes the items in the previous figure.

Item Description

Access IP number Click the drop-down menu to select the number of IP addresses to 
define (0 to 32). The default setting (0) disables this setting.

Save Click Save to save the values and update the screen.

Item Description

Choose File Click Choose File to select the configuration file.

Submit Click Submit to backup the settings.
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Chapter 7

7Telnet/Serial Console 
Configuration



 

7.1 Overview
The purpose of the Console Configuration is to help you manage your device in con-
sole mode. One of the main functions of the console mode is to change the web con-
figuration login password. You can use terminal software like Hyper Terminal, Telix
and other related terminal software.

7.2 Telnet Console
Create a new connection

You can create a new Telnet connection and assign a connection name for the con-
sole configuration.

Figure 7.1 Creating a Telnet Connection

Input the IP address

Confirm that the Telnet console configuration works ok. Be sure that your host PC
Ethernet network IP domain is as same as the EKI-1528-DR serial device server, and
the Telnet TCP port number is “23”.
8.

Figure 7.2 Creating a Telnet Connection

Connection Success
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After connecting to the serial device server in HyperTerminal console, a welcome
greeting displays.

Figure 7.3 Telnet Connection Console

At the command prompt, you can type a “help” followed by the Enter button, or <Tab>
twice, to display the command list. 

You can toggle between the different command menu options. 

7.3 Command List

system

Usage: system

  Show current device status and informations.

Command Function Description

system Show or configure the system information

port Show or configure the serial ports information

portadv Show or configure the serial ports advanced settings

mvcom Show or configure the serial ports in Virtual COM mode

mctr Show or configure the serial ports in Control mode (USDG)

mdata Show or configure the serial ports in Data mode (USDG)

net Show or configure the Ethernet ports settings

password Set or change the password

alarm Show or configure the auto warning functions including mail alarm and 
SNMP alarm

monitor Monitor the serial ports status

mrfc2217 Show all port modes and mode information.

apply Write settings to the flash memory and reboot the system immediately

exit Terminate the shell session

help Display command list help informationt

reboot Write settings and reboot the system immediately.
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Usage: system name [Maximum length 31 bytes]

  Set current device name.

Usage: system desc [Maximum length 127 bytes]

  Set current device description.

port

Usage: port [nn|all]

  Show port status and informations.

Usage: port [nn] desc [Maximum length 127 bytes]

  Set serial port description.

Usage: port [nn|all] type [232|422|485] flow []

  flow 0:None.

  flow 1:XOn/XOff.

  flow 2:RTS/CTS.

  flow 3:DTR/DSR.

  Set serial port type and flow control.

Usage: port [nn|all] baud [50-921600] parity [] data [5-8] stop [1|1.5|2]

  acceptable baud: 50 75 110 150 300 600 1200 1800 2400 4800 7200 9600

                   14400 19200 38400 57600 115200 230400 460800 921600

  parity n: None Parity.

  parity e: Even Parity.

  parity o: Odd Parity.

  parity m: Mark Parity.

  parity s: Space Parity.

  Set serial baud rate, parity and numbers of data bits, numbers of stop bits.

Usage: port [nn|all] mode [vcom|ctrl|data]

  Set serial port as virtual COM port or control mode or data mode.

$ help portadv

portadv

  Show port advanced setting.

Usage: portadv [nn|all] delayT []

  Set delay time(ms).

Usage: portadv [nn|all] ignorepurge [TRUE|FALSE] dischato [TRUE|FALSE] dismulti-
con [TRUE|FALSE]

  Enable or disable the feature of ignore purge,

  disable character timeout detection,

  and disable multiple connection.

Usage: portadv [nn|all] databuf []

  Set databuffer threshold.

Usage: portadv [nn|all] timeout [] rtl [] ttl [] fcl [] fch []

  Set port timeout ,

  and set portrtl, portttl, portfcl, portfch.

Usage: portadv [nn|all] fifosize [size|null]

  Set port Writed size of FIFO, null for disable

Usage: portadv [nn|all] rts []

  Set port RTS status.

  value 0 :None Setting.
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  value 1 :Setting power on.

  value 2 :Setting accept on.

  value 4 :Setting transmission on.

Usage: portadv [nn|all] dtr []

  Set port DTR status.

  value 0 :None Setting.

  value 1 :Setting power on.

  value 2 :Setting accept on.

  value 4 :Setting transmission on.

mvcom

Usage: mvcom

  Show all port mode and mode informations.

Usage: mvcom [nn|all]

  Set port [nn|all] as virtual COM port mode.

Usage: mvcom [nn|all] idleto []

  Set host idle timeout(s).

Usage: mvcom [nn|all] respto [] framebk []

  Set response timeout(ms) and frame break(ms).

Usage: mvcom [nn|all] bysize []

Usage: mvcom [nn|all] bytime []

Usage: mvcom [nn|all] bychar [NULL|]

  Set datapackage as size(bytes) or time(ms) and character(HEX) .

  value 0 : None Setting.

mctrl

Usage: mctrl

  Show port mode and mode informations.

Usage: mctrl [nn|all]

  Set port [nn|all] as control mode.

Usage: mctrl [nn|all] idleto [] tcpp [] atp [] guardt [] hangchr []

  Set data idle timeout(s) data listen port command listen port

  guard time(ms) hangup character.

mdata

Usage: mdata

  Show port mode and mode informations.

Usage: mdata [nn|all]

  Set port [nn|all] as data mode.

Usage: mdata [nn|all] protocol [TCP|UDP]

  Set transmit protocol as TCP or UDP.

Usage: mdata [nn|all] idleto [] lsport [] atport []

  Set data idle timeout(s) listen port and AT command port.

Usage: mdata [nn|all] respto [] framebk []

  Set response timeout(ms) and frame break(ms).

Usage: mdata [nn|all] bysize [] bytime [] bychar [NULL|] bychartimeout [ON|OFF]

  Set datapackage as size(bytes) or time(ms) or character(HEX) and charactertime-
out.

  value 0 : None Setting.
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Usage: mdata [nn|all] autopeerip [ON|OFF]

  Set auto connect to peer ip as on or off.

Usage: mdata [nn|all] peernum [1-16] peer [d.d.d.d:d] ...

  Set peer IP address and port for receive data.

net

Usage: net [1|2]

  Show device network status and informations.

Usage: net [1|2] mode [static|dhcp|bootp|all]

  Set network operating mode.

Usage: net [1|2] ip [d.d.d.d] netmask [d.d.d.d] gw [d.d.d.d]

  Set IP address and subnet mask and gateway.

Usage: net [1|2] dns [auto|specific]

  Enable/Disable DNS.

Usage: net [1|2] dns1 [d.d.d.d]

  Set network DNS1.

Usage: net [1|2] dns2 [d.d.d.d]

  Set network DNS2.

Usage: net [1|2] to [d]

  Set network timeout.

password

Usage: password

  Display two different Usage.

Usage: password new [1-31 characters]

  Set new password.

Usage: password old [**...] new [1-31 characters]

  Confirm the old password and set new password.

alarm

Usage: alarm

  Show current alarm informations.

Usage: alarm mail server [null|address] from [null|address] to1 [null|address] to2
[null|address] to3 [null|address] to4 [null|address]

  Set current mail server configuration.

Usage: alarm trap server [null|address] ver [1|2] community [null|name]

  Set current trap server configuration.

Usage: alarm agent rcommunity [null|name] wcommunity [null|name] contact
[null|name] location [null|name]

  Set current snmp agent configuration.

Usage: alarm event mail [cstart] [wstart] [auth] [ip] [passwd] [eth1] [eth2]

  Set current mail event configuration.

Usage: alarm event trap [cstart] [wstart] [auth] [eth1] [eth2]

  Set current trap event configuration.

Usage: alarm port [1|2|..] dcd [none|mail|trap|all] dsr [none|mail|trap|all]

  Set current port alarm configuration.

monitor

Usage: monitor port [1|2|..] setting

  Monitor COM port setting
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Usage: monitor port [1|2|..] statistic

  Monitor COM port statistic data

Usage: monitor port [1|2|..] ip

  Monitor connected IP

time

Usage: time

  Show current time informations.

Usage: time [YYYYMMDDhhmmss]

  Set current time configuration.

Usage: time ntp [timeserver]

  Set current time server configuration.

service

Usage: service telnet [enable|disable]

  Enable/Disable telnet function

Usage: service snmp [enable|disable]

  Enable/Disable SNMP function

mrfc2217

Usage: mrfc2217

  Show all port mode and mode informations.

Usage: mrfc2217 [nn|all]

  Set port [nn|all] as RFC2217 mode.

Usage: mrfc2217 [nn|all] idleto [] lsport []

  Set host idle timeout(s) and listen port.

apply

Usage: apply

Save the settings to flash and reboot right now.

exit

Usage: exit

Terminate shell session

help

Usage: help [cmd]

Display help information of command cmd

reboot

Usage: reboot

Write settings and reboot the system immediately.
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Appendix A

ATCP and UDP Port 
Numbers
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A.1 List of Known TCP and UDP Port Numbers

Port Protocol Service

5048 (TCP/UDP) Configuration Utility

5058 (TCP/UDP) Configuration Utility

5202 (TCP) VCOM/RVCOM

9999 (TCP) Firmware Download

22 (TCP) SSH

23 (TCP) Telnet

25 (TCP) SMTP (Mail Client)

53 (TCP/UDP) DNS

67 (UDP) BOOTP Server/DHCP

68 (UDP) BOOTP Client/DHCP

80 (TCP) Web Interface/HTTP

123 (TCP) NTP

161 (TCP) SNMP

162 (TCP/UDP) SNMP Trap

443 (TCP) HTTPS

502 (TCP) Modbus/TCP (Default)

514 (TCP) Syslog

546 (TCP/UDP) DHCPv6 Client

547 (TCP/UDP) DHCPv6 Server
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